Page tree
Skip to end of metadata
Go to start of metadata

This article is part of the Protecting WordPress index, but can be generally applied to your account and security practices! 

These updates are important as they fix bugs, close security holes, and add functionality.

The most important part of updating is patching known security issues, as hackers will scan for particular versions of WordPress and attempt to crack in with these known vulnerabilities.

  • Do the same for any themes or plugins you have installed - updates are vital to account security.
  • If you worry about themes or plugins being broken with updates, you need to utilize different themes or plugins - the providers of these addons should be keeping up with the WordPress updates to keep users like you as secure and functional as possible.
  • If you're not a developer you should look at plugins/themes with paid update or support options, as these will be more likely to help keep your website secure.